Communauté

» Tutoriels »

Bug de mise à jour (écran noir) Bug rencontré sur le canal : devel-proposed
Avatar
Par MetallicaMust - Le 29/07/2014 à 22h28

Formateur

rank_4.png

Inscrit le: 23/02/2014

Messages: 310


Comme il est arrivé, avec la version r150 puis avec la version r155 d'ubuntu Touch 14.10, que la mise à jour, pour des raisons obscures, se passe mal et que l'on se retrouve avec un écran noir et que c'est vraiment pas cool, voilà la solution testée par moi-même sur Nexus 4. Notez que ceci concerne le canal : devel-proposed. Il faut aussi que le "Mode développer" du téléphone (ou tablette) soit activé pour que cela fonctionne !


Solution 1 :
Cette solution permet de récupérer un appareil fonctionnel en gardant les fichiers persos, les applications installées et toute votre configuration.

  1. Attendre qu'au moins une nouvelle mise à jour soit disponible. Par exemple, si le bug c'est produit avec la version r150, il faut s'assurer qu'au moins la version r151 ait été publiée.
  2. A ce moment là, connectez votre appareil à votre ordinateur via le câble USB.
  3. Assurez-vous que votre appareil soit allumé (l'écran est noir mais rétro-éclairé).
  4. Ouvrez un TERMINAL (ou CONSOLE) et tapez le code suivant. Code :
    ubuntu-device-flash --channel=devel-proposed
  5. Il faut attendre assez longtemps même s'il semble qu'il ne se passe rien, ne touchez à rien jusqu'à ce que la mise à jour se fasse sur votre appareil.



Solution 2 :
Si la "Solution 1" n'a pas fonctionné alors que 4 ou 5 nouvelles mises à jour ont été publiées, il faudra alors se résigner à envisager de refaire une installation complète en perdant tous les dossiers perso, toute les applications installées ainsi que toute la configuration. C'est la dernière solution à envisager... Tentez de persister avec la "Solution 1" avant d'entreprendre celle-ci.

  1. Connectez votre appareil à votre ordinateur via le câble USB.
  2. Assurez-vous que votre appareil soit allumé (l'écran est noir mais rétro-éclairé).
  3. Ouvrez un TERMINAL (ou CONSOLE) et tapez le code suivant. Code :
    ubuntu-device-flash --channel=devel-proposed --bootstrap
  4. Il faut attendre assez longtemps, ne touchez à rien jusqu'à ce que l'installation se fasse après le formatage de la mémoire de votre appareil.



Bien entendu, et comme toujours, vous êtes seul responsable de votre appareil et d'éventuels dégâts subis en ayant suivi les manipulations présentées ici, même si cette possibilité est hautement improbable ! Néanmoins, nous serons à votre disposition pour tenter de vous aider en cas de problème.



Edité par MetallicaMust Le 03/10/2014 à 15h22


Equipement : Nexus 4, Nexus 7 Wifi 2013, Aquaris E4.5 Ubuntu Edition et Aquaris M10 FHD Ubuntu Edition.

Jean Ferrat : "Ils n'en finissent pas, tes artistes prophètes, de dire qu'il est temps que le malheur succombe"
Site web    
Avatar
Par MetallicaMust - Le 27/09/2014 à 18h45

Formateur

rank_4.png

Inscrit le: 23/02/2014

Messages: 310


Bon, moi j'ai un très gros problème :(

C'est toujours un problème d'écran noir après une mise à jour sauf que là, je ne sais pas comment m'en sortir parce que quand je me connecte à l'ordi via USB, mes Nexus 4 et 7 ne sont pas reconnu. je n'ai que la possibilité de démarrer mes appareil en mode "bootloader". Ca fait 3 jours que je me bat sans succès. Je ne peux rien faire...

En "Recovery mode" je n'ai que très peu d'option qui ne servent à rien pour ce problème... je ne sais vraiment plus quoi faire :(

Qui peux m'aider ?


--------------
EDIT

Je précise que toute les commandes dans le TERMINAL me retourne un insupportable :
"error: device not found"



Edité par MetallicaMust Le 27/09/2014 à 19h36


Equipement : Nexus 4, Nexus 7 Wifi 2013, Aquaris E4.5 Ubuntu Edition et Aquaris M10 FHD Ubuntu Edition.

Jean Ferrat : "Ils n'en finissent pas, tes artistes prophètes, de dire qu'il est temps que le malheur succombe"
Site web    
Avatar
Par jimmy - Le 27/09/2014 à 20h54

Administrateur

rank_admin.png

Groupe: Administrateur

Inscrit le: 20/05/2013

Messages: 1707


Force la commande en indiquant le nom de ton appareil dedans example :

ubuntu-device-flash --channel=devel-proposed --device=mako --bootstrap
Avatar
Par MetallicaMust - Le 28/09/2014 à 00h08

Formateur

rank_4.png

Inscrit le: 23/02/2014

Messages: 310


Je fais sans --bootstrap

Ca ne fonctionne toujours pas, j'obtiens ca :

[date] [heure] Device is |mako|
[date] [heure] Flashing version 259 from devel-proposed channel and server https://system-image.ubuntu.com to device mako
[date] [heure] ubuntu-touch/utopic-proposed is a channel alias to devel-proposed
[date] [heure] Cannot cleanup /cache/recovery/ to ensure clean deploymentexit status 255


pareil avec --device=flo (pour le nexus 7).


Je précise que sans le nom de l'appareil j'obtiens ca :

[date] [heure] Expecting the device to expose an adb interface...
[date] [heure] exit status 255



J'ai testé avec --bootstrap et ca bloque après le téléchargement des fichiers images (.tar.xz) même en attendant une éternité de temps et rien ne se passe sur les appareils.

pffffff... quel galère :(



Edité par MetallicaMust Le 28/09/2014 à 00h15


Equipement : Nexus 4, Nexus 7 Wifi 2013, Aquaris E4.5 Ubuntu Edition et Aquaris M10 FHD Ubuntu Edition.

Jean Ferrat : "Ils n'en finissent pas, tes artistes prophètes, de dire qu'il est temps que le malheur succombe"
Site web    
Avatar
Par jimmy - Le 28/09/2014 à 10h12

Administrateur

rank_admin.png

Groupe: Administrateur

Inscrit le: 20/05/2013

Messages: 1707


Avatar
Par MetallicaMust - Le 28/09/2014 à 14h09

Formateur

rank_4.png

Inscrit le: 23/02/2014

Messages: 310


Ouais, ca a fonctionné, merci ;)



pfffff... faut tout refaire maintenant :(


Equipement : Nexus 4, Nexus 7 Wifi 2013, Aquaris E4.5 Ubuntu Edition et Aquaris M10 FHD Ubuntu Edition.

Jean Ferrat : "Ils n'en finissent pas, tes artistes prophètes, de dire qu'il est temps que le malheur succombe"
Site web    
Avatar
Par jimmy - Le 28/09/2014 à 16h46

Administrateur

rank_admin.png

Groupe: Administrateur

Inscrit le: 20/05/2013

Messages: 1707


^^ j'ai toujours la solution :p malheureusement oui faut que tu refasse tout sinon passe sur la rtm t'aura pas les nouveauté mais je pense plus de bug d'écran noir ...
Avatar
Par MetallicaMust - Le 02/10/2014 à 21h28

Formateur

rank_4.png

Inscrit le: 23/02/2014

Messages: 310


Là je suis en "devel-proposed", mais je vais plutot passé en "devel" parce que je veux quand-même suivre l'évolution ;)


Equipement : Nexus 4, Nexus 7 Wifi 2013, Aquaris E4.5 Ubuntu Edition et Aquaris M10 FHD Ubuntu Edition.

Jean Ferrat : "Ils n'en finissent pas, tes artistes prophètes, de dire qu'il est temps que le malheur succombe"
Site web    
Avatar
Par jimmy - Le 03/10/2014 à 07h38

Administrateur

rank_admin.png

Groupe: Administrateur

Inscrit le: 20/05/2013

Messages: 1707


Avatar
Par MetallicaMust - Le 03/10/2014 à 15h20

Formateur

rank_4.png

Inscrit le: 23/02/2014

Messages: 310


Ah, je sais pourquoi ma solution du premier message n'a pas fonctionné !

Il faut impérativement que le "Mode développer" du téléphone (ou tablette) soit activé pour que cela fonctionne !

Malheureusement pour moi, et pour une raison inconnue, le "Mode développer" a été désactivé :(

----
Le plus long sera de recréer le répertoire de contacts :(


Equipement : Nexus 4, Nexus 7 Wifi 2013, Aquaris E4.5 Ubuntu Edition et Aquaris M10 FHD Ubuntu Edition.

Jean Ferrat : "Ils n'en finissent pas, tes artistes prophètes, de dire qu'il est temps que le malheur succombe"
Site web    
Avatar
Par jimmy - Le 03/10/2014 à 20h14

Administrateur

rank_admin.png

Groupe: Administrateur

Inscrit le: 20/05/2013

Messages: 1707


Avatar
Par mailcom - Le 18/10/2014 à 12h54

Initié

rank_0.png

Inscrit le: 18/10/2014

Messages: 3


Bonjour,
Je rencontre le même problème mais la commande ubuntu-device-flash --clean-cache me renvoie Cleaning previously downloaded content.
Je suis complètement bloqué.

Est-ce que quelqu'un peut m'aider ? Merci.
   
Avatar
Par jimmy - Le 19/10/2014 à 11h04

Administrateur

rank_admin.png

Groupe: Administrateur

Inscrit le: 20/05/2013

Messages: 1707


Avatar
Par mailcom - Le 19/10/2014 à 16h08

Initié

rank_0.png

Inscrit le: 18/10/2014

Messages: 3


Pour être complet :

- Je branche le téléphone (Nexus 4) sur USB, mon PC (sous Ubuntu) ne réagit pas et le téléphone clignote en rouge.
- Dans le terminal : "adb devices" retourne une liste vide
- Dans le terminal : "ubuntu-device-flash --clean-cache" retourne "Cleaning prevously downloaded content"
- Dans le terminal : "ubuntu-device-flash --channel=devel-proposed" retourne "exit status 255"
- Dans le terminal : "ubuntu-device-flash --channel=devel-proposed --bootstrap" --> "waiting" puis plus rien...
   
Avatar
Par jimmy - Le 19/10/2014 à 20h28

Administrateur

rank_admin.png

Groupe: Administrateur

Inscrit le: 20/05/2013

Messages: 1707


copie moi la totalité quand tu fait :
ubuntu-device-flash --channel=devel-proposed

les lignes avant peuvent être importante aussi.

Et dis moi les commandes tu les lances depuis l'écran noir ou en Bootloader (logo android)

» Tutoriels »

Répondre
Vous n'êtes pas autorisé à écrire dans cette catégorie
2 Utilisateurs en ligne : 0 Administrateur, 0 Modérateur, 0 Membre et 2 Visiteurs
Utilisateurs en ligne : Aucun membre connecté